Food Allergy Support is now on Twitter. Follow us @FASupport. You may also follow our Tweets in our new global footer at the bottom of the page here at FAS!

Author Topic: Weird - thread link title problem  (Read 1374 times)

Description:

Offline sbs

  • New Member
  • **
  • Posts: 24
Weird - thread link title problem
« on: June 01, 2012, 08:35:48 PM »
I pm'd somebody earlier today and included a link to one of the threads from the school board.  However, the link was replaced by the name of another thread from OT.  If I click on the link (from the message in my sent folder), it brings me to the correct thread in schools, but the thread title name that this site automatically put in is wrong.

Has anybody else had this problem? 
« Last Edit: June 01, 2012, 08:39:19 PM by sbs »
USA

Offline AdminCM

  • Administrator
  • Member
  • *****
  • Posts: 2,925
Re: Weird - thread link title problem
« Reply #1 on: June 02, 2012, 10:09:29 PM »
Hmmm.

I'm recalling something like this when we were first setting things up over here.


I'll bet it has to do with the way that posts are indexed in the main portion of the board versus in PM's.

Does it usually work properly, or is this the first time you've tried to embed a link and you just noticed it??


Offline sbs

  • New Member
  • **
  • Posts: 24
Re: Weird - thread link title problem
« Reply #2 on: June 03, 2012, 06:40:24 AM »
This is definitely the first time I noticed that happening since I set up this account a few months ago.

I think it was the first time I tried to link in a pm.  At first I thought I made a mistake and tried to resend, but the wrong automatic title happened again.

I didn't want to bother this person I was trying to send the pm to, but I was annoyed, so I sent the link to somebody I know better here and it worked fine with no mistakes (the site put in the correct thread title).

I don't think that I've used links too often in my messages on the schools board yet, but I'll keep an eye on how they are working when/if I do.

sbs
USA

Offline rebekahc

  • Global Moderator
  • Member
  • ****
  • Posts: 2,969
Re: Weird - thread link title problem
« Reply #3 on: June 05, 2012, 10:18:09 AM »
It has to do with how you got to the thread.  If you went there from the main index, it will work, but if you got there by clicking "show unread posts" or "new", etc. it changes the link and messes up the title.  I've turned in a bug report, but they haven't fixed it yet.  The only way to fix it is to remove the confusing parts of your link or only use the link from going there directly.

This link with the #new at the end (from clicking the "new" button)
Code: [Select]
http://foodallergysupport.olicentral.com/index.php/topic,5584.msg6506.html#new
gives us this:  Re: School issues...need advice ASAP!!  WRONG

but if I use this
Code: [Select]
http://foodallergysupport.olicentral.com/index.php/topic,5584.0.html
I get this:  Tree Nut/Peanut FREE body washes  CORRECT!

Both links go to where they're supposed to, the first one just confuses the part of the program that assigns it the correct title.  <sigh>
TX - USA
DS - peanut, tree nut, milk, eggs, corn, soy, several meds, many environmentals. Finally back on Xolair!
DD - mystery anaphylaxis, shellfish.
DH - banana/avocado, aspirin.  Asthma.
Me - peanut, tree nut, shellfish, banana/avocado/latex,  some meds.

Offline sbs

  • New Member
  • **
  • Posts: 24
Re: Weird - thread link title problem
« Reply #4 on: June 05, 2012, 11:46:55 AM »
Thanks for the info rebekahc!

I'll pay more attention to how I'm entering threads and whether the correct title is being inserted when referencing them.

Hopefully, they'll fix the bug soon.
USA